Sep 21

在Linux上安装mod_security 不指定

Heck , 14:58 , 电脑技术 , 评论(0) , 引用(0) , 阅读(854) , Via 本站原创 | |
       在使用apache的httpd服务器时,安全是你不得不考虑的一个问题。mod_security是为apache httpd服务器(1.x和2.x)设计的一个安全模块,mod_security可以阻止多种形式的攻击,比如SQL注入,跨站点脚本等等。这篇文章说明了如何在各种Linux上安装mod_security:

RHEL / CentOS

在CentOS / RHEL上安装mod_security,最简单的办法就是使用yum进行自动更新。首先需要新建一个更新的yum repository:

vi /etc/yum.repos.d/utterramblings.repo

在这个文件中加入以下内容:


之后用yum进行自动更新:

yum install mod_security

然后重启httpd

service httpd restart

注意如果httpd的版本不对的话这里可能会出现一些错误。这个时候你需要更新apache的版本:

yum update httpd

然后再重启httpd就可以了

Fedora

对于Fedora只需要使用yum进行安装就可以了:

yum install mod_security

yum update httpd

之后

service httpd restart

Debian / Ubuntu

对于Debian或者Ubuntu,可以使用以下命令进行安装:




来源:Heck's Blog
地址:http://www.hecks.tk/linux-setup-apache-mod-security-httpd-safety/
转载时须以链接形式注明作者和原始出处及本声明,否则将追究法律责任,谢谢配合!